Need JavaScript and the latest version of Flash player. Get Flash here.